System Requirements

Lucid Builder System Requirements

The Lucid Builder requires a Java Runtime Environment (JRE). Two options are currently available. The choice depends on your organisation or preference. Both work equally well and make no difference to the operation of the Lucid Builder.

  1. Oracle Java Runtime Environment (licence required).
    See: https://www.java.com
  2. Open Source Java Runtime Environment (free)
    See: https://adoptopenjdk.net/releases.html

The Lucid Builder supports operating systems that the JRE is available under.

windows

Windows

mac

OSX

linux

Linux

solaris

Solaris