Search  
 

Please login to post into the forums. Remember - keep your posts friendly. 

Note: Identic Pty Ltd reserves the right to remove any material it considers inappropriate or offensive. Please report any undesirable posts or behaviour to support@lucidcentral.org.

If you have any direct support requests such as reactivation requests please use the help desk.

  
 

Login

    
 
HomeHomeLucid Phoenix D...Lucid Phoenix D...Phoenix FAQsPhoenix FAQsWhat are the system requirements for Lucid Phoenix?What are the system requirements for Lucid Phoenix?
Previous
 
Next
New Post
3/20/2008 1:23 PM
 

The Java Virtual Machine (JVM) v1.4.2 or greater needs to be installed on your computer. The JVM is provided with the CD ROM edition of Lucid Phoenix. To obtain the latest version of the JVM for free, go to www.java.com. Users who want to download the demonstration version of Lucid Phoenix or who want to view the Lucid Phoenix player will need to download it from www.java.com, if not already installed. To check if you have the JVM installed or what version you may already have. See the following FAQ.

To install the JVM, your computer needs to meet one of the following.

Windows OS
• 98/ME/NT(SP6a)/2000(SP3)/XP(SP1)
• Pentium 166MHz
• HD: 75MB
• RAM: 64MB

Please note: The JVM no longer supports Windows 95.

Macintosh OS
• OS X 10.2.6 or greater
• HD: 51MB
• RAM: 128MB

Linux OS
• A flavour of Linux that supports J2RE, such as: Red Hat 7.3/8.0 SuSE 8.0, Ubuntu etc
• Pentium 166MHz
• HD: 85MB
• RAM: 64MB

Solaris OS: 7, 8 or 9
• RAM: 128MB
• HD: Up to 70MB

 
Previous
 
Next
HomeHomeLucid Phoenix D...Lucid Phoenix D...Phoenix FAQsPhoenix FAQsWhat are the system requirements for Lucid Phoenix?What are the system requirements for Lucid Phoenix?


  
Copyright 2017. All rights reserved. Identic Pty
Terms Of Use  Privacy Statement